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Error de restricción: Las transacciones de una cuenta bancaria solo se pueden importar una vez

Error o incidencia

Al intentar cargar un archivo CSV correspondiente al estado de cuenta de BanCoppel, el sistema Odoo muestra el siguiente mensaje de advertencia, impidiendo su importación:

error

Este error se presenta aun cuando el archivo es nuevo y no ha sido procesado previamente.

Causa Raíz

El error es generado por una limitación en el formato de archivo proporcionado por BanCoppel, el cual no incluye identificadores únicos por transacción. Debido a esto, el sistema no puede distinguir si algunas transacciones ya fueron previamente registradas.

Detalles identificados:

  • Las líneas 34 y 36 del archivo son consideradas duplicadas por el sistema.

error

  • Existen inconsistencias en las columnas de saldo, lo cual también puede contribuir a la detección incorrecta de duplicados.

  • Aunque el archivo es nuevo, las transacciones que coinciden exactamente en contenido con otras ya cargadas anteriormente son bloqueadas por Odoo para evitar duplicidad.

Impacto

  • Impide el registro oportuno de los pagos realizados por los clientes.
  • Retrasa el proceso contable y de conciliación bancaria diaria.
  • Requiere intervención manual en cada carga afectada.

Solución

Modificar el archivo CSV antes de cargarlo:

  • Editar las líneas 34 y/o 36, agregando un carácter adicional (por ejemplo, una letra o símbolo) en la columna de concepto o descripción.

  • Esto permite que el sistema las reconozca como únicas y no las identifique como duplicadas.

  • Alternativamente, si se confirma que las transacciones ya fueron cargadas, eliminar esas líneas del archivo.

Archivo compartido por el cliente

Se adjunta el archivo proporcionado por el cliente como referencia, con el fin de contar con un ejemplo para el análisis y documentación de futuros errores similares al presente caso.

Descargar Archivo

Ejemplos de archivo de banco Bancoppel:

descarga de ejemplos de los avances